Securexion Daily Exploit Watch - 22 Oct 2026

Critical PHP memory safety flaws in all supported versions (8.2–8.5) allow unauthenticated remote code execution via out-of-memory and global state corruption. Patch immediately.

Share

Critical PHP memory safety flaws in all supported versions (8.2–8.5) allow unauthenticated remote code execution via out-of-memory and global state corruption. Patch immediately.

Critical · CVSS 9.8CVE-2026-109618, CVE-2026-109619

PHP remote code execution via use-after-free in memory management

Two critical vulnerabilities in PHP's out-of-memory handling and global state management leave freed request memory accessible to subsequent requests, allowing remote code execution without authentication or user interaction. All supported PHP versions 8.2 through 8.5 are affected.

What to do: Update PHP immediately to 8.2.35, 8.3.36, 8.4.27, or 8.5.12 depending on your branch; isolate any older instances pending patching.

Read the full analysis →


Securexion is the daily exploit watch by FutureOps InfoTech. Need help patching or checking for compromise? Talk to us.

Read more